TYPO3’te home.html not found hatası ve giderilmesi


TYPO3 ile ilk tanışmamda bir kaç hata ile karşılaştım. Bunlardan birincisi php_openssl ve php_fileinfo uzantılarının etkin olmayışından dolayı kurulumun başlamaması oldu. Zaten kurulum sayfasında bu uzantılar etkin değilse uyarı mesajı veriyor.

Karşılaştığım ikinci sorun ise zaman aşımı meselesi idi. Veritabanı oluşturulur ve içine kayıtlar eklenirken, varsayılan olarak 30 saniyeye ayarlanan işlem süresi sınırı yetersiz kaldığı için işlem yarıda kalıyordu. Bunu da php.ini dosyasındaki (benim dosyamda 440. satırda bulunan)

max_execution_time = 30

satırını

max_execution_time = 300

olarak değiştirerek atlattım. 30 saniyelik zaman sınırını 300 saniyeye çıkarttım. Bunu kurulumdan sonra tekrar eski haline aldım.

Gelelim esas meseleye…

Kurulum başarıyla tamamlandı ve siteyi görmek için sabırsızlanıyorum. Web sitesini ziyaret etmek için bağlantıya tıkladığımda

Not Found

The requested URL /typo3_gov/home.html was not found on this server.

sorunuyla karşılaştım. Bu sefer biraz düşünmeye başladım. Sonra web sitesinin klasöründe böyle bir dosya olur olmadığına baktım. Kök klasörde sadece index.php dosyası ve bir kaç .txt dosyası görünüyordu. Aklıma rewrite modülünün etkin olup olmadığına bakmak geldi. Apache modüllerinden url_rewrite modülü etkin değildi.

Bunu da etkinleştirdikten sonra bu sorunum da çözüldü.

Aynı dertten muzdarip olanlara duyurulur.

Bir Cevap Yazın

Aşağıya bilgilerinizi girin veya oturum açmak için bir simgeye tıklayın:

WordPress.com Logosu

WordPress.com hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Twitter resmi

Twitter hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Facebook fotoğrafı

Facebook hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Google+ fotoğrafı

Google+ hesabınızı kullanarak yorum yapıyorsunuz. Log Out / Değiştir )

Connecting to %s